Função SE - Questão

Observe a fórmula aplicada na célula A5 de uma planilha do Excel 2000, em sua configuração original:
=SE(A3<=500;A3/2;(SE(E(A3>550;A3<=1000);A3*20%;A3*10%)))
Indique a alternativa que traz o resultado que será exibido na célula A5 quando os seguintes valores forem inseridos na célula A3:
I. 500 - II. 550 - III. 1000
(A) I. 200; - II. 275; - III. 500.
(B) I. 250; - II. 55; - III. 200.
(C) I. 500; - II. 0; - III. 1000.
(D) I. 50; - II. 110 ; - III. 100.
(E) I. 1.5; - II. #ERRO; - III. #ERRO.

Bom para começarmos vamos entender como funciona a função SE.
=SE(pergunta;"resposta sim";"resposta não")
Analisando a questão acima vemos que teremos uma função dentro da outra o que chamamos de função aninhada e portanto temos que analisar por etapas:
=SE(A3<=500...Essa é nossa primeira pergunta e se a resposta for verdadeira será mostrado A3/2, se a resposta não for verdadeira teremos outra função Se começando
SE(E(A3>550;A3<=1000) e ai temos o "E" que nos indica que teremos duas perguntas separadas por vírgula e ambas tem que ser verdadeira para mostrarmos a resposta SIM. Se for verdadeira teremos como resposta: A3*20% e se uma das opções do pergunta forem falsas ele mostrara o resultado da seguinte operação: A3*10%¨.
Bom agora que tivemos uma rápida explicação de como trabalha a função SE, vamos ver as respostas...
Na pergunta ele trás 3 opções e na primeira temos 500, ou seja, A3 no primeiro caso vale 500 e ai vemos a função:
=SE(500<=500;A3/2;(SE(E(500>550;500<=1000);500*20%;500*10%)))
Bom...500 é menor ou igual a 500? SIM então ele vai mostrar a resposta de 500/2 = 250
no segundo caso vamos substituir A3 por 550.
=SE(550<=500;A3/2;(SE(E(550>550;550<=1000);550*20%;550*10%)))
550 é menor ou igual a 500? NÃO então ele ira para o segundo SE que seria a resposta não...we ai começa de novo...550>550 e 550<=1000? NÃO então ele fará 550*10% = 55
por fim.
=SE(1000<=500;A3/2;(SE(E(1000>550;1000<=1000);1000*20%;1000*10%)))
1000<=500? NÃO então ele ira para o segundo SE que seria a resposta não...we ai começa de novo...1000>550 e 1000<=1000? SIM então ele fará 1000*20% = 200.
Sendo assim a resposta é B.